incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Koelmeyer <dave.koelme...@davekoelmeyer.co.nz>
Subject Re: Quick search has stopped working
Date Sat, 09 Mar 2013 06:48:35 GMT
On 24/02/13 10:37 PM, Dirk Frederickx wrote:
> You may want to delete the lucene indexes, and restart jspwiki. (so it will
> build new search indexes)


Hi Dirk,

Thanks for your reply - I've stopped the domain, deleted the entire 
contents of the JSPWiki working directory and fired it back up again. It 
doesn't look like there is a change in behaviour however.

I've got a screen grab here: http://ubuntuone.com/5EVUvzZx9pMd52pheDPkbB

Top right is what I'm seeing presently. Bottom left is a historical 
screen grab, and you can see for the same search term the difference in 
returned results. Differences between the two are newer versions of 
JSPWiki, GlassFish and Java, and a heavily customised theme.

Any other ideas would be awesome.

Cheers,
Dave


>
>
>
>
> On Sun, Feb 24, 2013 at 8:54 AM, Dave Koelmeyer <
> dave.koelmeyer@davekoelmeyer.co.nz> wrote:
>
>> On 24/02/13 11:32 AM, Dirk Frederickx wrote:
>>
>>> Dave,
>>>
>>> Can you check the javascript console of the browser ?  ( in chrome,  Tools
>>> => Javascript Console)
>>>
>>> So you can identify if this is a browser/js issue (eg javascript routines
>>> not loaded?)   or server issue (eg no response on the ajax search queries)
>>>
>>>
>>> dirk
>>>
>> Hi Dirk,
>>
>> Thanks for the reply. I've checked with a variety of browsers and no
>> JavaScript errors are logged to the web console at all.
>>
>> Strangely, I've noticed I do actually receive search results for some
>> queries - but at maximum only four total (where as in the very recent past
>> I've had over a dozen for the same search query). I thought perhaps this
>> might be a cache memory issue, and reading through the docs I see that it's
>> best to have the jspwiki.workDir value explicitly set in jspwiki.properties
>> ("The working directory is used to cache things like Lucene search") - I've
>> done this and restarted the app server but with no change in behaviour.
>>
>> Could this behaviour be related to the size of my wiki? It has probably
>> several hundred entries at present and in total the content size is 170MB.
>> If anything has changed it's been the content uploaded to the wiki, and not
>> anything else to my knowledge.
>>
>>
>>
>>
>>   Hi All,
>>>> Yesterday it worked, today it has stopped working. When typing in a
>>>> keyword in my JSPWiki search bar, I would usually have dozens of search
>>>> hits returned dynamically. This has stopped working altogether, and
>>>> nothing
>>>> is returned dynamically. I was using JSPWiki 2.8.3, upgrading to 2.9.0
>>>> hasn't changed the behaviour (has fixed a couple of other bugs though
>>>> which
>>>> is lovely). I'm using GlassFish 3.1.2.2 with JDK 6 update 37, all on
>>>> OpenIndiana oi_151a7.
>>>>
>>>> Any pointers to what might have gone wrong here?
>>>>
>>>> Cheers,
>>>> Dave
>>>>
>


-- 
Dave Koelmeyer
http://blog.davekoelmeyer.co.nz


Mime
View raw message