incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Pablo Santos Rodríguez <juanpablo.san...@gmail.com>
Subject Re: /JSPWiki prepended to paths..
Date Thu, 07 Feb 2013 23:49:58 GMT
Hi Jim,

are you running JSPWiki behind an apache web server? If so, please check
[#1], [#2] and [#3] for possible answers and configurations.

Also, have you checked that the jspwiki.properties file has the same values
as before the upgrade/reinstall? especially regarding the url constructor
and the baseUrl


HTH,
juan pablo

[#1] http://s.apache.org/4VD
[#2] http://www.jspwiki.org/wiki/ApacheTomcatConnection
[#3] http://www.jspwiki.org/wiki/JSPWikiAsRootContextWithApache



On Thu, Feb 7, 2013 at 11:38 PM, Jim Willeke <jim@willeke.com> wrote:

> All of the access want to pre-pend /JSPWiki to the Links as shown below:
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/scripts/prettify.js HTTP/1.1" 404 1036
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/scripts/mootools.js HTTP/1.1" 404 1036
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/scripts/jspwiki-commonstyles.js HTTP/1.1" 404 1072
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/scripts/jspwiki-common.js HTTP/1.1" 404 1054
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/templates/default/jspwiki.css HTTP/1.1" 404 1066
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET /JSPWiki/images/out.png
> HTTP/1.1" 404 1021
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/templates/default/jspwiki_print.css HTTP/1.1" 404 1084
> 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/images/favicon.ico HTTP/1.1" 404 1033
> 192.168.1.57 - - [07/Feb/2013:17:26:38 -0500] "GET /JSPWiki/wiki/
> Services.willeke.biz HTTP/1.1" 404 1054
>
> This was not the case before I re-installed.
> If I remove the " /JSPWiki" then I can access the resources like:
> /templates/default/jspwiki.css
>
> Any ideas?
>
> 2.8.4 on Tomcat6 using Suse Enterprise Server 11.2.
>
> Thanks
>
>
> --
> -jim
> Jim Willeke
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message