incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Willeke <...@willeke.com>
Subject Re: /JSPWiki prepended to paths..
Date Fri, 08 Feb 2013 09:25:43 GMT
Thanks for the help.

Not behind anything. (Yet).

The only thing that changed in the properties file are:
from:
jspwiki.fileSystemProvider.pageDir = /srv/www/htdocs/ldapwiki/
jspwiki.workDir =/srv/tomcat/temp/ldapwiki/
jspwiki.basicAttachmentProvider.storageDir =
/srv/www/htdocs/ldapwiki/attachments/
jspwiki.baseURL=http://ldapwiki.willeke.com/

To:
jspwiki.fileSystemProvider.pageDir = /srv/tcdocs/ldapwiki/
#jspwiki.workDir =/srv/tomcat/temp/ldapwiki/
jspwiki.basicAttachmentProvider.storageDir =
/srv/tcdocs/ldapwiki/attachments/
#jspwiki.baseURL=http://ldapwiki.willeke.com/
jspwiki.baseURL=http://ldapwiki.willeke.com:8080/

Due to some differences in how the system was configured.

Any other ideas?



--
-jim
Jim Willeke


On Thu, Feb 7, 2013 at 6:49 PM, Juan Pablo Santos Rodríguez <
juanpablo.santos@gmail.com> wrote:

> Hi Jim,
>
> are you running JSPWiki behind an apache web server? If so, please check
> [#1], [#2] and [#3] for possible answers and configurations.
>
> Also, have you checked that the jspwiki.properties file has the same values
> as before the upgrade/reinstall? especially regarding the url constructor
> and the baseUrl
>
>
> HTH,
> juan pablo
>
> [#1] http://s.apache.org/4VD
> [#2] http://www.jspwiki.org/wiki/ApacheTomcatConnection
> [#3] http://www.jspwiki.org/wiki/JSPWikiAsRootContextWithApache
>
>
>
> On Thu, Feb 7, 2013 at 11:38 PM, Jim Willeke <jim@willeke.com> wrote:
>
> > All of the access want to pre-pend /JSPWiki to the Links as shown below:
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/scripts/prettify.js HTTP/1.1" 404 1036
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/scripts/mootools.js HTTP/1.1" 404 1036
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/scripts/jspwiki-commonstyles.js HTTP/1.1" 404 1072
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/scripts/jspwiki-common.js HTTP/1.1" 404 1054
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/templates/default/jspwiki.css HTTP/1.1" 404 1066
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> /JSPWiki/images/out.png
> > HTTP/1.1" 404 1021
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/templates/default/jspwiki_print.css HTTP/1.1" 404 1084
> > 192.168.1.57 - - [07/Feb/2013:17:26:33 -0500] "GET
> > /JSPWiki/images/favicon.ico HTTP/1.1" 404 1033
> > 192.168.1.57 - - [07/Feb/2013:17:26:38 -0500] "GET /JSPWiki/wiki/
> > Services.willeke.biz HTTP/1.1" 404 1054
> >
> > This was not the case before I re-installed.
> > If I remove the " /JSPWiki" then I can access the resources like:
> > /templates/default/jspwiki.css
> >
> > Any ideas?
> >
> > 2.8.4 on Tomcat6 using Suse Enterprise Server 11.2.
> >
> > Thanks
> >
> >
> > --
> > -jim
> > Jim Willeke
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message