incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Koelmeyer <dave.koelme...@davekoelmeyer.co.nz>
Subject Re: Quick search has stopped working
Date Sun, 24 Feb 2013 07:54:07 GMT
On 24/02/13 11:32 AM, Dirk Frederickx wrote:
> Dave,
>
> Can you check the javascript console of the browser ?  ( in chrome,  Tools
> => Javascript Console)
>
> So you can identify if this is a browser/js issue (eg javascript routines
> not loaded?)   or server issue (eg no response on the ajax search queries)
>
>
> dirk

Hi Dirk,

Thanks for the reply. I've checked with a variety of browsers and no 
JavaScript errors are logged to the web console at all.

Strangely, I've noticed I do actually receive search results for some 
queries - but at maximum only four total (where as in the very recent 
past I've had over a dozen for the same search query). I thought perhaps 
this might be a cache memory issue, and reading through the docs I see 
that it's best to have the jspwiki.workDir value explicitly set in 
jspwiki.properties ("The working directory is used to cache things like 
Lucene search") - I've done this and restarted the app server but with 
no change in behaviour.

Could this behaviour be related to the size of my wiki? It has probably 
several hundred entries at present and in total the content size is 
170MB. If anything has changed it's been the content uploaded to the 
wiki, and not anything else to my knowledge.

Cheers,
Dave

-- 
Dave Koelmeyer
http://blog.davekoelmeyer.co.nz



>> Hi All,
>>
>> Yesterday it worked, today it has stopped working. When typing in a
>> keyword in my JSPWiki search bar, I would usually have dozens of search
>> hits returned dynamically. This has stopped working altogether, and nothing
>> is returned dynamically. I was using JSPWiki 2.8.3, upgrading to 2.9.0
>> hasn't changed the behaviour (has fixed a couple of other bugs though which
>> is lovely). I'm using GlassFish 3.1.2.2 with JDK 6 update 37, all on
>> OpenIndiana oi_151a7.
>>
>> Any pointers to what might have gone wrong here?
>>
>> Cheers,
>> Dave
>>
>> --
>> Dave Koelmeyer
>> http://blog.davekoelmeyer.co.**nz <http://blog.davekoelmeyer.co.nz>
>>
>>



Mime
View raw message