incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joseph Mocker <m...@fakebelieve.org>
Subject Re: Profile Security NOT WORKING!!!
Date Thu, 31 Mar 2011 19:15:53 GMT
All this commotion got the best of me, so I gave it a spin. Plus I'm 
running 2.4 and I probably should really upgrade.

At any rate, seemed to work for me, here's what I did:

   1. Spun up a new Ubuntu Server 10.10 X64 VM
   2. Created install folder /app
   3. Downloaded JDK 1.6.0_24 X64 from Oracle
   4. Installed Java into /app/jdk1.6.0_24
   5. export JAVA_HOME=/app/jdk1.6.0_24
   6. Downloaded Tomcat 6.0.32
   7. Installed Tomcat in /app/web/apache-tomcat-6.0.32
   8. Started up Tomcat to make sure its working. It was. Shut it down.
   9. Downloaded JSPWiki 2.8.4
  10. Installed JSPWiki into /app/web/sites/default/webapps/wiki
  11. Installed corepages into /app/web/sites/default/webapps/wiki
  12. Edited jspwiki.properties to fix paths for pageDir and storageDir
  13. Created Tomcat webapp descriptor in
      /app/web/apache-tomcat-6.0.32/conf/Catalina/localhost/wiki.xml
      (attached)
  14. Started up Tomcat hit the /wiki/Installer.jsp page in browser.
  15. Restarted Tomcat. Verified I could create files as anonymous, and
      I could login to admin account.
  16. Changed WEB-INF/jspwiki.policy (attached) file so that only logged
      in users can create/modify pages.
  17. Restarted Tomcat. Verified I could not created/modify pages until
      I logged in.

Seemed pretty straight forward to me. Much easier than getting JSPWiki 
2.4 with a custom jspwiki.policy to work with Sun Java System Web Server 
7.0.

:-)

  The Security Configuration Verifier showed the exact permissions of 
what I could do.

   --joe


On 3/31/2011 6:28 AM, George, Kenneth V [NTK] wrote:
> ...AND...on my test machine (local) I am using  1.6.0_24
>
> C:\Documents and Settings\kvg6037>java -version
> java version "1.6.0_24"
> Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
> Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode, sharing)
>
> -----Original Message-----
> From: Janne Jalkanen [mailto:Janne.Jalkanen@ecyrd.com]
> Sent: Thursday, March 31, 2011 1:42 AM
> To:jspwiki-user@incubator.apache.org
> Subject: Re: Profile Security NOT WORKING!!!
>
>
> This is odd, since I'm running on same JSPWiki, Ubuntu 10.04, Tomcat 6.0.32 (which is
BTW a recommended upgrade; Chrome 10 breaks on occasion otherwise), and I have jspwiki.policy
working. However, I am running OpenJDK 6b20-1.9.7-0ubuntu1~10.04.1.
>
> Is it possible that for some reason Sun JDK's built-in policy management is kicking in
here? Or that it might just be broken in some odd fashion. Can you try OpenJDK and see if
that works for you?
>
> /Janne


Mime
View raw message