incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Buntin" <dbun...@econtrols.com>
Subject RE: Login works with Chrome but not IE7?
Date Thu, 28 May 2009 06:42:07 GMT
For the archive...

IE7 cannot properly manage cookies and browser sessions are broken when the
web domain name includes an underscore. Read the following for more info on
this bug:
http://blogs.creative-jar.com/post/Session-Cookies---Bug-in-IE7.aspx

In my case, I was using an internal WinXP machine with a computer name that
contains an underscore as my JSPWiki server. The underscore in the JSPWiki
URL exposed this bug in IE7. I solved the problem by renaming the computer.

Thanks for your help,
David
 

-----Original Message-----
From: David Buntin [mailto:dbuntin@econtrols.com] 
Sent: Wednesday, May 27, 2009 9:57 AM
To: 'jspwiki-user@incubator.apache.org'
Subject: RE: Login works with Chrome but not IE7?

Dirk, if IE7 works for you on jspwiki.org, then there is an issue with my
instance. Do you have any suggestion for how I might debug the IE7 problem
that I'm having on my instance of JSPWiki?

Thanks,
David 
-----Original Message-----
From: Dirk Frederickx [mailto:dirk.frederickx@gmail.com] 
Sent: Tuesday, May 26, 2009 12:19 PM
To: jspwiki-user@incubator.apache.org
Subject: Re: Login works with Chrome but not IE7?

Yep. I did a few tests myself, and I am perfectly able to login using IE7.
(using jspwiki.org)I did notice a problem with the UserPref screen during my
login tests. (JSPWIKI-561)

But  I did notice that the login form does not show error messages when
submitted under IE7.  So problably something is going wrong during the
submit.
Strange we didn't notice this before...

More testing needed ;-)


dirk


On Tue, May 26, 2009 at 3:45 PM, David Buntin <dbuntin@econtrols.com> wrote:

> Thanks Dirk. I checked "Java logging enabled" in IE7 advanced options and
> then looked for a javalog.txt file in the Windows/Java directory. No file
> was generated. Assuming I have done the correct thing, this seems to mean
> that no javascript errors are occurring. Am I correct?
>
> David
>
> -----Original Message-----
> From: Dirk Frederickx [mailto:dirk.frederickx@gmail.com]
> Sent: Monday, May 25, 2009 2:52 PM
> To: jspwiki-user@incubator.apache.org
> Subject: Re: Login works with Chrome but not IE7?
>
> David,
>
> As this seems to be a browser/IE7 specific issues, may it could be
> javascript related.
> Can you check if there is a js error when submitting the login page.
>
>
> In IE, you can set the option to catch all javascript error and get some
> error info. That would be very useful.
>
>
>
> dirk
>
>
> On Mon, May 25, 2009 at 8:25 PM, Janne Jalkanen
> <janne.jalkanen@ecyrd.com>wrote:
>
> >
> > Andrew, Dirk, any ideas?
> >
> > /Janne
> >
> >
> > On 25 May 2009, at 19:45, David Buntin wrote:
> >
> >  Thanks for helping. I tried 2.8.2 with no luck. IE7 still constantly
> >> redirects to the login page. Any other suggestions?
> >>
> >> David
> >> -----Original Message-----
> >> From: Janne Jalkanen [mailto:janne.jalkanen@ecyrd.com]
> >> Sent: Saturday, May 23, 2009 4:35 AM
> >> To: jspwiki-user@incubator.apache.org
> >> Subject: Re: Login works with Chrome but not IE7?
> >>
> >>
> >> Could you try 2.8.2, please? There were some changes made into the
> >> login process after 2.8.1, so those might
> >> be helping you.
> >>
> >> (Aside from that, congrats on being the first Chrome user to come out
> >> of the closet on this mailing list ;-)
> >>
> >> /Janne
> >>
> >> On 23 May 2009, at 01:23, David Buntin wrote:
> >>
> >>  I have successfully deployed JSPWiki 2.8.1 in Tomcat5.5 and
> >>> Apache2.2 on a
> >>> WinXP machine. When using Google's Chrome, a proper login attempt
> >>> results
> >>> correctly in a redirect to the main page. With IE7, a proper login
> >>> attempt
> >>> re-directs back to the login page.
> >>>
> >>> We use JSPWiki as a common internal-use-only scratchpad within our
> >>> small
> >>> company. We only want known folks using the wiki. I've configured
> >>> security
> >>> to restrict any anonymous or asserted user to the login page only.
> >>> Furthermore, anonymous and asserted users cannot create an account. I
> >>> control access to the wiki via manual edits to the userdatabase.xml
> >>> file.
> >>> Here are the jspwiki.policy entries:
> >>>
> >>> grant principal com.ecyrd.jspwiki.auth.authorize.Role "All" {
> >>>    permission com.ecyrd.jspwiki.auth.permissions.WikiPermission "*",
> >>> "login";
> >>> };
> >>> grant principal com.ecyrd.jspwiki.auth.authorize.Role "Anonymous" {
> >>> };
> >>> grant principal com.ecyrd.jspwiki.auth.authorize.Role "Asserted" {
> >>> };
> >>> grant principal com.ecyrd.jspwiki.auth.authorize.Role
> >>> "Authenticated" {
> >>>    permission com.ecyrd.jspwiki.auth.permissions.PagePermission
> >>> "*:*",
> >>> "view";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.WikiPermission "*",
> >>> "editPreferences";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.WikiPermission "*",
> >>> "editProfile";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.PagePermission
> >>> "*:*",
> >>> "modify,rename";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.GroupPermission
> >>> "*:*",
> >>> "view";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.GroupPermission
> >>> "*:<groupmember>", "edit";
> >>>    permission com.ecyrd.jspwiki.auth.permissions.WikiPermission "*",
> >>> "createPages,createGroups";
> >>> };
> >>> grant principal com.ecyrd.jspwiki.auth.GroupPrincipal "Admin" {
> >>>    permission com.ecyrd.jspwiki.auth.permissions.AllPermission "*";
> >>> };
> >>> grant principal com.ecyrd.jspwiki.auth.authorize.Role "Admin" {
> >>>    permission com.ecyrd.jspwiki.auth.permissions.AllPermission "*";
> >>> };
> >>>
> >>> Is there a solution to my IE7 login problem?
> >>>
> >>> Thanks in advance,
> >>> David
> >>>
> >>
> >
>
>


Mime
View raw message