incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harry Metske <harry.met...@gmail.com>
Subject Re: Users successfully authenticated but not logged in
Date Wed, 21 Jan 2009 13:26:55 GMT
compare the value of the baseURL prop (in jspwiki.properties) with the
actual value you use in your browser, they should be the same.

Harry

2009/1/21 Roland Whitehead <roland@quru.com>

> I have 2 jspwiki installs. Both appear to me to be identical in their
> jspwiki.policy and jspwiki.properties.
>
> One works correctly but the other is giving me issues with logging in.
>
> If I try to log in and then tail the jspwiki.log I see the following:
>
> 2009-01-21 11:43:50,967 [http-8080-8] INFO SecurityLog Wiki:/wiki/Login.jsp
> Wiki:http://wiki.40fires.org/wiki/Login.jsp -
> WikiSecurityEvent.LOGIN_AUTHENTICATED
> [source=com.ecyrd.jspwiki.auth.AuthenticationManager@86db7,
> princpal=com.ecyrd.jspwiki.auth.WikiPrincipal <username>,
> target=com.ecyrd.jspwiki.WikiSession@9b1696]
> 2009-01-21 11:43:50,968 [http-8080-8] INFO JSPWiki Wiki:/wiki/Login.jsp
> Wiki:http://wiki.40fires.org/wiki/Login.jsp - Successfully authenticated
> user <username> (custom auth)
> 2009-01-21 11:43:50,968 [http-8080-8] INFO JSPWiki Wiki:/wiki/Login.jsp
> Wiki:http://wiki.40fires.org/wiki/Login.jsp - Redirecting user to
> http://wiki.40fires.org/Wiki.jsp?page=Main
>
> however, the page still says "G'day, <username> (not logged in)" and I
> can't access the pages that the ACL's say I should be logged in to access.
> It's the same for the Admin user as well.
>
> I have run admin/SecurityConfig.jsp and all seems fine.
>
> Any hints as to what I am doing wrong? I'm guessing its a permissions thing
> somewhere in my install but so far have got nowhere.
>
> TIA
>
> Roland
> --
> QURU Ltd, London

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message