incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Jaquith <andrew.jaqu...@me.com>
Subject Re: Login Problem
Date Thu, 25 Sep 2008 17:19:11 GMT
Benedikt -- what version of JSPWiki are you using? The 2.8 beta wires  
up its own JAAS stack, and does not require any fiddling with  
container JAAS configs. If you are using JSPWiki 2.6, you should give  
2.8 a try instead.

Andrew

On Sep 25, 2008, at 12:25 PM, Benedikt Mohrmann wrote:

> Hi,
>
> does anybody know how to fixx this?
>
> Best regards
> Benedikt
>
>
> Benedikt Mohrmann schrieb:
>> Hi,
>>
>> I am running JSPWiki on a JBoss Server.
>> As described on the homepage, I added a new policy into "login- 
>> config.xml".
>> I am able to register new users, but unable to login with them!
>>
>> Stacktrace says:
>> 2008-09-24 10:52:18,375 [http-localhost%2F127.0.0.1-8080-1] ERROR  
>> SecurityLog JSPWiki:/JSPWiki/Login.jsp JSPWiki:http://localhost:8080/JSPWiki/Login.jsp

>>  - WikiSecurityEvent.LOGIN_FAILED  
>> [source=com.ecyrd.jspwiki.auth.AuthenticationManager@e13c84,  
>> princpal=com.ecyrd.jspwiki.auth.WikiPrincipal Guest,  
>> target=com.ecyrd.jspwiki.WikiSession@c54b3b]
>> 2008-09-24 10:52:18,375 [http-localhost%2F127.0.0.1-8080-1] INFO  
>> JSPWiki JSPWiki:/JSPWiki/Login.jsp JSPWiki:http://localhost:8080/JSPWiki/Login.jsp

>>  - Failed to authenticate user test
>>
>> I tried it with Tomcat, too- there were no problems.
>>
>> Regards
>> Benedikt
>


Mime
View raw message