incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Obermeier <michael.oberme...@unico-group.com>
Subject Re: Installation problem - Page directory does not exist?
Date Mon, 21 Jul 2008 13:12:37 GMT
Hello Matt,

I had the same problems during first tests. You have to correct the path to 
your directories where you store your wikipages and attachements are not
specified in the jspwiki.properties.

Search for jspwiki.fileSystemProvider.pageDir and
jspwiki.basicAttachmentProvider.storageDir in the jspwiki.properties.


Michael

Matt Burkhardt <mlb@imparisystems.com> schrieb: 
>

Still trying - but went and restarted Tomcat to see what kind of errors
>I might be getting on start up and now I have 
>
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO:  Assigning new engine to 11053084
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO: No jspwiki.propertyfile defined for this context, using default
>from /WEB-
>INF/jspwiki.properties
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO: Loading cascading properties...
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO:  No cascading properties defined for this context
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO: JSPWiki: Unable to load and setup properties from
>jspwiki.properties. Fail
>ed to start managers: Page directory does not exist
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.ApplicationContext log
>INFO: ERROR: Failed to create a Wiki engine: JSPWiki: Unable to load and
>setup p
>roperties from jspwiki.properties. Failed to start managers: Page
>directory does
> not exist
>Jul 21, 2008 8:31:01 AM org.apache.catalina.core.StandardContext
>filterStart
>SEVERE: Exception starting filter WikiServletFilter
>com.ecyrd.jspwiki.InternalWikiException: No wiki engine, check logs.
>        at com.ecyrd.jspwiki.WikiEngine.getInstance(WikiEngine.java:340)
>        at
>com.ecyrd.jspwiki.ui.WikiServletFilter.init(WikiServletFilter.java:55
>)
>        at
>org.apache.catalina.core.ApplicationFilterConfig.getFilter(Applicatio
>nFilterConfig.java:221)
>        at
>org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(Applica
>tionFilterConfig.java:302)
>        at
>org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFi
>lterConfig.java:78)
>        at
>org.apache.catalina.core.StandardContext.filterStart(StandardContext.
>java:3635)
>        at
>org.apache.catalina.core.StandardContext.start(StandardContext.java:4
>222)
>        at
>org.apache.catalina.startup.HostConfig.checkResources(HostConfig.java
>:1105)
>        at
>org.apache.catalina.startup.HostConfig.check(HostConfig.java:1203)
>        at
>org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java
>:293)
>        at
>org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(Lifecycl
>eSupport.java:120)
>        at
>org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBas
>e.java:1306)
>        at org.apache.catalina.core.ContainerBase
>$ContainerBackgroundProcessor.p
>rocessChildren(ContainerBase.java:1570)
>        at org.apache.catalina.core.ContainerBase
>$ContainerBackgroundProcessor.p
>rocessChildren(ContainerBase.java:1579)
>        at org.apache.catalina.core.ContainerBase
>$ContainerBackgroundProcessor.r
>un(ContainerBase.java:1559)
>        at java.lang.Thread.run(Thread.java:619)
>Jul 21, 2008 8:38:45 AM org.apache.catalina.core.ApplicationContext log
>I
>On Mon, 2008-07-21 at 07:24 -0400, Matt Burkhardt wrote:
>
>> I followed the quick installation, but I'm getting a 404 - file not
>> found error when I try to bring up the JSPWiki or JSPWiki/Install.jsp
>> 
>> I know I have Tomcat5.5 installed correctly - there's two other sites
>> that are up and running.  I checked to make sure that all the files and
>> directories had the same owner as the two other applications that work -
>> but I'm at a loss.
>> 
>> The 404 error page is not the Apache 404 error page - but another the
>> Tomcat error page.
>> 
>> Anyway, I'm running it all on Ubuntu 8.04 with Tomcat 5.5 and Java 6
>> 
>> I've checked the Tomcat error logs and haven't found any clues.
>> 
>> Thanks,
>> 
>> Matt Burkhardt, MSTM
>> President
>> Impari Systems, Inc.
>> ?401 Rosemont Avenue
>> Frederick, MD  21701
>> mlb@imparisystems.com
>> www.imparisystems.com
>> (301) 644-3911
>> 
>> 
>
>Matt Burkhardt, MSTM
>President
>Impari Systems, Inc.
>?401 Rosemont Avenue
>Frederick, MD  21701
>mlb@imparisystems.com
>www.imparisystems.com
>(301) 644-3911
>
>
>
>
-- 
Michael Obermeier
UNICO Media GmbH
Softwareentwicklung & Support
Aldringenstraße 4

80639 München
UNICO Media GmbH
Geschäftsführer Christian Fuchs
Amtsgericht HRB 116178
Sitz der Gesellschaft ist München


Tel. +49-(0)89-1893533-21
Fax  +49-(0)89-1893533-11



Mime
View raw message