incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From luca80 <luca.andrea...@eng.it>
Subject Re: JONAS - Policy problem
Date Tue, 29 Jul 2008 15:56:47 GMT

I found that Jonas reads his own policy file which, by default, is like this:

grant {
  // Allow everything for now
  permission java.security.AllPermission;
};

So it allow every permission to all and this is a problem, because it
overrides the JSPWiki permissions that I try to add in the same file.
I tried to comment the default Jonas permission, but, in this way, even
Jonas can't run! >-(

Anyone can help me?

Thanks, 
Luca


luca80 wrote:
> 
> Hi All, 
> I have a problem with JONAS that isn't reading the JSPWiki policy file.
> 
> I'm using JSPWiki 2.6.2, JONAS 4.8.6 with Tomcat 5.5.17.
> 
> I tried also JSPWiki 2.6.2 in Tomcat 5.5.26, without Jonas, and it works.
> Is there any setting that I'm missing? Is there any known problems with
> Jonas?
> 
> All I did is this: 
> I simply moved some permissions from Authenticated group to a new Group
> called Test. I added some users to this group and when I log in as a user
> of this group I can see the differences in the permissions in Tomcat, but
> not in Jonas.
> 
> In Tomcat I modified this files:
> userdatabase.xml
> groupdatabase.xml
> jspwiki.policy
> jspwiki.properties
> 
> In Jonas I had to add the classes defined in jspwiki.jaas in the
> jaas.config of Jonas.
> I see that there is also a java.policy in the conf dir of Jonas, is that
> the problem?
> 
> Thanks for any suggestion,
> Luca.
> 

-- 
View this message in context: http://www.nabble.com/JONAS---Policy-problem-tp18713683p18715483.html
Sent from the JspWiki - User mailing list archive at Nabble.com.


Mime
View raw message