incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Phelan <Chris.Phe...@Sun.COM>
Subject Re: ToC problem
Date Thu, 08 May 2008 09:40:42 GMT
Janne,

Thanks for getting back to me.

I've just solved the problem. As well as having the ToC in the left 
menu, the Example page also had a ToC in its page content, and it seems 
that only one ToC is allowed. If I remove the ToC from the page content, 
the left menu ToC works. Since the Info tab didn't have a ToC it worked 
there anyway.

I've attached screenshots of the 'broken' and 'working' Example page, 
just in case anyone doesn't understand what I'm talking about.

Thanks for your time.

Chris




Janne Jalkanen wrote:
>
> Hmm... Seems to work quite well on sandbox.jspwiki.org (which is 
> 2.7.0-svn-9, but still).  Could you please supply some more info?  
> Like the actual plugin invocation you used, and also a screenshot or two?
>
> /Janne
>
> On 7 May 2008, at 17:06, Chris Phelan wrote:
>
>> Hi,
>>
>> I'm experimenting with JSPWiki 2.6.2 and found it to be pretty usable 
>> for the most part, but I have a curious problem with the Table of 
>> Contents plugin.
>>
>> I've read the docs at
>>
>> http://www.jspwiki.org/wiki/TableOfContentsPlugin
>>
>> which state that !!!headings should be listed in the ToC.
>>
>> I tried editing the default Main page to place a ToC in the Left 
>> Menu, and sure enough it works as advertised.
>> The problem is that I also wrote an Example page (with !!!headings) 
>> and the ToC just doesn't seem to work when on the 'View' tab - it 
>> only works on the 'Info' tab.
>>
>> I can supply screenshots if it helps explain the issue, but has 
>> anyone experienced similar misbehaviour, or am I missing something 
>> obvious?
>>
>> Thanks,
>>
>> Chris
>>
>


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message