incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sakari.aalto...@tkk.fi
Subject Re: Failed to create a Wiki engine
Date Sun, 11 May 2008 06:21:24 GMT
Lainaus Janne Jalkanen <Janne.Jalkanen@ecyrd.com>:

> This is the reason - for some reason your installation seems to have
> decided to try to instantiate a WikiEngine (and since it can't find a
> page directory, it fails) *before* you've run the Install script.
>
> So something odd is going on...

If I put JSPWiki.war into $CATALINA_HOME/webapps and Apache/Tomcat is  
running, then after a few seconds, the directory  
$CATALINA_HOME/webapps/JSPWiki appears without me doing anything. On  
the other hand, if I delete said JSPWiki.war, then after a few  
seconds, the directory $CATALINA_HOME/webapps/JSPWiki disappears, too  
(without me doing anything.)

>
> As a temporary measure, you can just go ahead and edit
> WEB-INF/jspwiki.properties by hand.  It's fairly well commented, so you
> should be fine.

I tried that, but I haven't got to the end, yet, as it is a rather  
large file. Well, I still get the
    The requested resource (/JSPWiki/) is not available.
error when accessing http://localhost:8080/JSPWiki (that is, not  
specifying Install.jsp.)


Sakari Aaltonen



Mime
View raw message