incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <Janne.Jalka...@ecyrd.com>
Subject Re: a little help with aFlashPlugin, please
Date Fri, 18 Jan 2008 20:31:01 GMT

Hm...  You should either add the package to the jspwiki.properties  
file (to the pluginPath setting), or someone should create a  
jspwiki_module.xml file which would allow the short name to be used  
automatically.

/Janne

On 18 Jan 2008, at 22:27, Vaughan Schmidt wrote:

> Just [{Flash...}] per instructions @
> http://www.jspwiki.org/wiki/AFlashPlugin.
>
> changing it to:
>
> [{arnaud.Flash ....}] works!  Woo-Hoo I'm in business!
>
> Thanks for the pointer!
>
> -Vaughan
>
> On Friday 18 January 2008 15:16:46 Janne Jalkanen wrote:
>> Are you using the fully qualified path of the plugin?  e.g.
>> [{com.something.or.other.Flash}], or just [{Flash}]?
>>
>> /Janne
>>
>> On 18 Jan 2008, at 15:07, Vaughan Schmidt wrote:
>>> (I am most likely just not that good at following directions, so
>>> I apologize up front if that is the case)
>>>
>>> I would like to use aFlashPlugin to embed "Wink" tutorials in my
>>> wiki.
>>>
>>> Base information:
>>>
>>> JSPWiki ver 2.4.106
>>>
>>> I have multiple wiki's setup (following general strategy of:
>>> http://doc.jspwiki.org/2.4/wiki/InstallingJSPWikiStepByStep)
>>>
>>> So, I have:
>>> wiki_tec stored in /wikis/wiki_tec
>>> wiki_IT stored in /wikis/wiki_IT
>>>
>>> Property files:
>>> /etc/wikis/wiki_tec.properties
>>> /etc/wikis/wiki_IT.properties
>>>
>>> I have separate tomcat webapps directories for wiki_tec, wiki_IT,
>>> etc.
>>>
>>> and so on...
>>>
>>> I have downloaded aFlashPlugin.zip to:
>>> /opt/tomcat-5.5.25/webapps/wiki_tec
>>>
>>> and unzipped, so that now I have files:
>>> /opt/tomcat-5.5.25/webapps/wiki_tec/scripts/Flash.js
>>> /opt/...../wiki_tec/WEB-INF/lib/aFlashPlugin.jar
>>>
>>> Tomcat as been stopped and restarted.
>>>
>>> When I embed the flash plugin tag in a wiki page, I get the
>>> message:
>>>
>>> "Plugin insertion failed: Could not find plugin Flash"
>>>
>>>
>>> I suspect the root cause has something to do with my multiple
>>> wiki set-up not being 100% correct - although wiki's seem to run
>>> fine for everything other than this plug-in (it is 1st plugin I
>>> have attempted)
>>>
>>> Any ideas / suggestions?
>>>
>>> Thank you
>>>
>>> V. Schmidt
>>>
>>> /opt/tomcat/webapps/wiki_tec
>


Mime
View raw message