incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milton Taylor <mcto...@gmail.com>
Subject Re: unable to login into jspwiki with jboss container authentication
Date Mon, 28 Jan 2008 08:29:21 GMT
I have the current version of jspwiki running against JBoss 4.2.2, and 
had earlier versions of both working together as well, so it does work!

Have you also uncommented the relevant section in web.xml?

What have you got in jboss-web.xml in your war's WEB-INF? Do you have a 
specific security domain there? (That matches the domain in the jboss 
security configuration?

Lastly, where have you put the jspwiki.policy file? THings have changed 
in 2.6.

Also, did you  realise you have to delete log4j.jar and commons-logging 
from your jspwiki WEB-INF folder? [Not related to security but can cause 
problems]

You can turn on detailed security logging in the log4j.xml 
file....should tell you why jspwiki can't get happening.  Don't do it 
from jspwiki.properties


KS Rogers wrote:
> Hi,
>
> I am unable to login to jspwiki with jboss container authentication. Below
> are the log messages that I get. I have enabled the container authentication
> in jspwiki.properties:
> jspwiki.authorizer = com.ecyrd.jspwiki.auth.authorize.WebContainerAuthorizer
>
> The authentication in jboss seems to be working fine, but is failing in
> jspwiki. Someone please help...
>
> I have these lines in jboss->users.properties
> rk=Admin, Authenticated, extern, intern, User
> rr=Admin
> tt=Admin
> tt.roles=Admin
>
> I have these lines in jboss->roles.properties
> rk=Admin, Authenticated, extern, intern, User
> rr=Admin
> tt=Admin
> tt.roles=Admin
>
>
> ...
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.login.XMLLoginConfigImpl  - End
> getAppConfigurationEntry(JSPWiki-container),
> authInfo=AppConfigurationEntry[]:
> [0]
> LoginModule Class: org.jboss.security.auth.spi.UsersRolesLoginModule
> ControlFlag: LoginModuleControlFlag: required
> Options:
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - initialize,
> instance=@16364317
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - Security domain: other
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - findResource: null
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - Properties
> file=file:/C:/install/Server/jboss-
> 4.0.5.GA/server/default/conf/users.properties, defaults=null
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] DEBUG
> org.jboss.security.auth.spi.UsersRolesLoginModule  - Loaded properties,
> users=[rr, tt, rk]
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - findResource: null
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - Properties
> file=file:/C:/install/Server/jboss-
> 4.0.5.GA/server/default/conf/roles.properties, defaults=null
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] DEBUG
> org.jboss.security.auth.spi.UsersRolesLoginModule  - Loaded properties,
> users=[tt.roles, rr, tt, rk]
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - login
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] TRACE
> org.jboss.security.auth.spi.UsersRolesLoginModule  - abort
> 2008-01-27 18:17:37,562 [http-0.0.0.0-8080-2] ERROR
> com.ecyrd.jspwiki.auth.AuthenticationManager  - Couldn't log in.
> Message=CallbackHandler does not support:
> javax.security.auth.callback.NameCallback@15e3b92
>
>   

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message