incubator-jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <janne.jalka...@iki.fi>
Subject Re: EmoticonsFilter in 2.6.0
Date Thu, 03 Jan 2008 15:59:40 GMT
On Thu, Jan 03, 2008 at 10:20:54AM -0500, Nascif Abousalh-Neto wrote:

> How about plugins? Is the 2.6 API backward compatible? I remember
> reading about changes that would break backward compatibility...

Yes, 3.0 will break compatibility (we need to rename the packages to org.apache).

However, plugins should work between 2.4 and 2.6, unless they were
relying on authorization or some deprecated API.

> That saved a lot of time in testing and choosing new plugins. I
> wonder if something like that would be useful to JSPWiki contributed
> code as well?

/Janne

Mime
View raw message