incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harry Metske (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JSPWIKI-746) Different versions of dependencies available at Central repo
Date Mon, 10 Sep 2012 20:04:07 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-746?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13452382#comment-13452382
] 

Harry Metske commented on JSPWIKI-746:
--------------------------------------

Just committed the stuff, I hope I haven ruined too much.
                
> Different versions of dependencies available at Central repo
> ------------------------------------------------------------
>
>                 Key: JSPWIKI-746
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-746
>             Project: JSPWiki
>          Issue Type: Sub-task
>    Affects Versions: Graduating, 2.9
>            Reporter: Juan Pablo Santos Rodríguez
>
> some libraries are present at Central, but with different versions: 
> - jrcs-diff-0.2.jar -> The closest match I was able to find is JMeld, a LGPL app which
includes the exact classes from jrcs-diff (among many others). There's also a newer version
of the library at Central, at [#3] but it includes a package rename. Other than, it seems
fine, but this might be the most delicate jar to upgrade.
> - jasper-*-5.5.25.jar [2 files] -> downgrade to 5.5.23? We use them to precompile
JSPs, downgrading shouldn't affect us and we could use the version from Central.
> - jetty-* [3 files] -> upgrade to 7.0.0.pre5 (5.1.14 11MB zip downloadable at http://dist.codehaus.org/jetty/jetty-5.1.x/jetty-5.1.14.tgz).
Have to locate the use of these jars to see the possible consequences of upgrading (there
are earlier versions on Central of jetty-*, except for the case of jetty-jmx, so it seems
safer to upgrade all three of them to 7.0.0.pre5)
> - selenium-*-1.0-beta-1 [2 files] -> upgrade them to 1.0-beta-2. Not very sure if
this could be done w/o changing code. If that's the case, we could try to upgrade to 1.0.2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message