incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Pablo Santos Rodríguez (JIRA) <>
Subject [jira] [Commented] (JSPWIKI-738) Dependencies should not be distributed with source archive
Date Thu, 19 Jul 2012 08:52:33 GMT


Juan Pablo Santos Rodríguez commented on JSPWIKI-738:

Hallo Florian,

I'll take a look this afternoon/tonight. Please reopen and attach relevant tomcat logs to
see what's happening.

Regarding servlet-api, we were including 2.4 although we're stating it should run on 2.3.
AFAIK it deploys on tomcat 5.5, so, theorically, we could probably downgrade the servlet-api
to 2.3. Haven't done tests on this, though.

juan pablo
> Dependencies should not be distributed with source archive
> ----------------------------------------------------------
>                 Key: JSPWIKI-738
>                 URL:
>             Project: JSPWiki
>          Issue Type: Task
>    Affects Versions: Graduating, 2.9
>            Reporter: Juan Pablo Santos Rodríguez
>            Assignee: Juan Pablo Santos Rodríguez
>             Fix For: Graduating, 2.9
> As pointed out in the revision of the July 2012 incubation report, JSPWiki ships binary
dependencies in the source archive, which is contrary to Apache principles.
> As we are downloading some dependencies in current trunk, I would take the path of downloading
all needed jars. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message