incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Holeczek (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (JSPWIKI-121) Drop support for JDK 1.4.
Date Sat, 10 Sep 2011 23:19:09 GMT

     [ https://issues.apache.org/jira/browse/JSPWIKI-121?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Florian Holeczek closed JSPWIKI-121.
------------------------------------


> Drop support for JDK 1.4.
> -------------------------
>
>                 Key: JSPWIKI-121
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-121
>             Project: JSPWiki
>          Issue Type: Task
>          Components: Servlet Container/Java compatibility
>            Reporter: Janne Jalkanen
>             Fix For: 2.8
>
>
> Since Java 6 has been out for a long time, it's time to move to JDK 5.  We already require
JDK 5 to compile (due to some MBean classes we are using), but JSPWiki 2.6 should also work
on JDK 1.4.
> However, JDK 5 does give us quite a lot of advantages, programming-wise.  It makes loops
nicer, and generics and annotations make life so much easier.
> This shift is targeted to 3.0. In theory, we could start moving to JDK 5 even earlier
in 2.8, unless there's a large amount of opposition.  It's my understanding though that quite
a few companies are still running JDK 1.4.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message