incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harry Metske (JIRA)" <>
Subject [jira] Commented: (JSPWIKI-646) Execption when running the .war file without unpacking it
Date Wed, 05 May 2010 11:53:02 GMT


Harry Metske commented on JSPWIKI-646:

My memory sometimes lets me down, so to record the current status:

I sent this note on the dev-list on May 1 2010:


one of the root causes of this problem lies in
(we have seen this before, but never really fixed it).
I tried to find the source, and tried to access, but it doesnt respond.
Could you send a source tarball or something, or do you want to fix it yourself ?


> Execption when running the .war file without unpacking it
> ---------------------------------------------------------
>                 Key: JSPWIKI-646
>                 URL:
>             Project: JSPWiki
>          Issue Type: Bug
>          Components: Servlet Container/Java compatibility
>    Affects Versions: 2.8.3, 3.0
>         Environment: Pax-Web 0.7.2, Felix 2.0.2, Pax-Runner
>            Reporter: Matthias K├╝spert
>            Assignee: Harry Metske
>            Priority: Minor
>         Attachments: jspwiki-conf-1.0.0-SNAPSHOT.jar, jspwiki.bnd
> When JSPWiki is run directly from the .war (not unpacking it into a directory) startup
fails with the following exception:
> java.lang.IllegalArgumentException: File /WEB-INF/jspwiki.policy does not exist, or the
SecurityManager prohibited access to it.
> 	at<init>(
> 	at
> 	at com.ecyrd.jspwiki.auth.AuthorizationManager.initialize(
> 	at com.ecyrd.jspwiki.WikiEngine.initialize(
> 	at com.ecyrd.jspwiki.WikiEngine.<init>(
> 	at com.ecyrd.jspwiki.WikiEngine.getInstance(
> 	at com.ecyrd.jspwiki.ui.WikiServletFilter.init(
> 	at org.mortbay.jetty.servlet.FilterHolder.doStart(
> Other files from WEB-INF are read without problems, e.g. web.xml:
> [FelixStartLevel] DEBUG org.ops4j.pax.web.service.jetty.internal.HttpServiceContext -
getting resource: [/WEB-INF/web.xml]
> [FelixStartLevel] DEBUG org.ops4j.pax.web.extender.war.internal.WebAppWebContainerContext
- Searching bundle [JSPWiki [1]] for resource [/WEB-INF/web.xml], normalized to [WEB-INF/web.xml]
> [FelixStartLevel] DEBUG org.ops4j.pax.web.extender.war.internal.WebAppWebContainerContext
- Resource found as url [bundle://1.0:36/WEB-INF/web.xml]
> [FelixStartLevel] DEBUG org.ops4j.pax.web.service.jetty.internal.HttpServiceContext -
found resource: bundle://1.0:36/WEB-INF/web.xml

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message