incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Jaquith <andrew.r.jaqu...@gmail.com>
Subject Re: some attachment questions
Date Mon, 08 Mar 2010 01:11:43 GMT
Dirk,

While I haven't looked into the exact bug you cited, I suspect one
reason why s:link may not have generated the correct link is because
of the url-encoded slashes that delimit the attachment path. I
mentioned this issue in an e-mail to the list about 2 weeks ago.

But, I won't know until I dig into it a little more.

Andrew

On Sun, Mar 7, 2010 at 3:45 PM, Dirk Frederickx
<dirk.frederickx@gmail.com> wrote:
> Andrew,
>
> No.  Two different ways to generate links will lead to mistakes and
> inconsistencies.
>
> Why can <s:link> not provide the correct jspwiki-compatible links ?
> And actually take over the functionality build info wiki:LinkTo ?
>
>
> dirk
>
> On Sun, Mar 7, 2010 at 4:42 PM, Andrew Jaquith
> <andrew.r.jaquith@gmail.com> wrote:
>>> I'd prefer to have a single solution for a jsp-author to include jspwiki links.
>>> If this can be done by the <s:link> that would be great.  But in that
>>> case, I would expect that correct links are generated, and that JSP
>>> author doesn't need to care.
>>> If this is not possilbe, I suggest to always use the <wiki:LinkTo>
>>> tags consistently.
>>
>> I don't think it matters. I do want JSP authors to be able to use both
>> so that they can't make a "mistake."
>>
>> Andrew
>>
>

Mime
View raw message