incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <>
Subject Re: Vote requested: package renaming
Date Thu, 01 Jan 2009 21:44:48 GMT

Totally agreed here...


On 1 Jan 2009, at 14:36, Siegfried Goeschl wrote:

> Hi folks,
> regarding interface package name - why not "org.apache.jspwiki.api"
> +) every developer on this planet would expect to find interface and
> simple domain object there
> +) using a seperate package would allow to extract the API from the  
> rest
> of the implementation project if needed (and is a good test if the API
> is self-contained)
> Cheers,
> Siegfried Goeschl
> Janne Jalkanen wrote:
>>> Janne's reply regarding timing of the rename is worth respecting. I
>>> would like to see more communication to the group regarding the
>>> expected conclusion of the JCR work. I would not like to see JCR
>>> delay the project for more than a couple of months. One reason for a
>>> community of folks working on the project. So while there's no need
>>> to rush things that are coming up quickly, we should try to avoid
>>> losing momentum.
>> *shrug*
>> I can commit the JCR work to trunk right away.
>> It just doesn't work, that's all.
>>> Refactoring interfaces from classes needs a corresponding class
>>> factory. Has this been thought through? There are good reasons for
>>> interfaces with factories, primarily driven by needing multiple
>>> independent implementations. But classes with exernally-written
>>> subclasses are also a good approach if most subclasses just need to
>>> change a small bit of behavior.
>> Correct, and we use that pattern with filters, for example.
>>> Splitting the stable interfaces apart from the implementation  
>>> doesn't
>>> necessarily need a new package name. Either org.apache.jspwiki or
>>> org.apache.jspwiki.api could be used.
>> And the question is which one...
>> /Janne

View raw message