incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <>
Subject Re: Movin' along
Date Sun, 21 Dec 2008 16:23:19 GMT
>    - I committed a few typo corrections, not important
>    - there should be package documentation, which tells the reader  
> at least
>    what you just said: *org.apache.jspwiki.api.* is the one you can  
> rely on.

Yup, good point.

>     Everything else *we will consider breakable without notice*.*
>    - WikiPage.getAcl() and .setAcl() refer to an ACL object which  
> is outside
>    the API package, that should not happen ?

True.  I think we should move the Acl and AclEntry classes into  
org.apache.jspwiki.api.acl, yes?

>    - WikiPage.getWiki() should indeed be renamed to  
> WikiPage.getWikiName()

I think I would prefer getSpace().

>    - do we need all the @since tags ?

I'm still wondering whether they should refer to API versions.

>    - if ModuleData is only about plugins we could probably rename  
> it to
>    PluginMetaData or something else.

Mmm... I think we need something for filters as well.  So it might  
make sense to split out some of the annotations out of the ModuleData  
which are plugin-specific.

BTW, I created a new issue: 
JSPWIKI-461 for tracking what should be done before an incubating  
release.  I think there are still several administrative issues (like  
whatever status raports, etc).  Then we probably need an issue for  
graduation as well.  I trust our mentors can review and tell us what  
stuff is missing?


View raw message