incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harry Metske" <harry.met...@gmail.com>
Subject Re: Movin' along
Date Sun, 21 Dec 2008 13:04:20 GMT
I had a look at the API package, just a few quick notes for what it's worth
:


   - I committed a few typo corrections, not important
   - there should be package documentation, which tells the reader at least
   what you just said: *org.apache.jspwiki.api.* is the one you can rely on.
    Everything else *we will consider breakable without notice*.*
   - WikiPage.getAcl() and .setAcl() refer to an ACL object which is outside
   the API package, that should not happen ?
   - WikiPage.getWiki() should indeed be renamed to WikiPage.getWikiName()
   - do we need all the @since tags ?
   - if ModuleData is only about plugins we could probably rename it to
   PluginMetaData or something else.

regards,
Harry

2008/12/20 Janne Jalkanen <Janne.Jalkanen@ecyrd.com>

> If it's going to be some time, perhaps it shouldn't gate the rename. I
>> assume that the JCR branch can be renamed as well if it isn't ready to
>> integrate.
>>
>
> I was planning a merge once I get it working, so that people don't have to
> deal with (too) broken code.
>
> But it's still not usable.
>
>>
>> Are you saying you want to wait until all the 40
>> plus-things-we-haven't-found-yet have been fixed before renaming, or before
>> release? I hope it's the latter.
>>
>
> Release.  The only reason we don't want to rename now is that merging back
> the JCR branch would be a pain.
>
>  At some point, 3.0 will need to have a first release, which is really what
>> the incubator is best at. Call it -alpha, call it -earlyaccess, call it
>> anything, but release it as an Apache release.
>>
>
> Hm?  We can do that?
>
>  We know that all applications that have plugins will need to change, and
>> it's important to get the code out there so folks have an idea of what they
>> are up against with the rename.
>>
>
> The rename is not the big problem; the API is the big problem.  Which is
> why I am worried that nobody else has commented on it...
>
> Just in case people haven't yet realized this - for plugin and filter
> writes, org.apache.jspwiki.api.* is the one you can rely on.  Everything
> else *we will consider breakable without notice*.
>
> (And for template writers, org.apache.jspwiki.tags.*, but there's no reason
> to change them, really. So they're already pretty stable.)
>
> /Janne
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message