incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Russell (JIRA)" <>
Subject [jira] Commented: (JSPWIKI-38) Rename packages to "org.apache.jspwiki"
Date Mon, 22 Dec 2008 23:33:44 GMT


Craig Russell commented on JSPWIKI-38:

> What I am looking for here is that I strongly believe that API classes should be isolated
in their own package hierarchy in order to provide a clear visual and logical separation of
the implementation classes. It does not have to be called "org.apache.jspwiki.api" - it could
also be called "org.jspwiki" or "" - whatever.

If you're in Apache, you're in the apache name space: org.apache.jspwiki or org.apache.whateverWeChangeTheNameToNext.

As far as I know, we're not talking about multiple independent implementations of a standard
or common API. So having an interface doesn't sound right.

But let's not continue on the thread of discussing keeping the com.ecyrd.jspwiki name space
in Apache. That is a non-starter.

> Rename packages to "org.apache.jspwiki"
> ---------------------------------------
>                 Key: JSPWIKI-38
>                 URL:
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>            Assignee: Janne Jalkanen
>             Fix For: 3.0

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message