incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Jaquith (JIRA)" <>
Subject [jira] Commented: (JSPWIKI-38) Rename packages to "org.apache.jspwiki"
Date Sat, 27 Dec 2008 14:24:44 GMT


Andrew Jaquith commented on JSPWIKI-38:

Janne -- 

I thought the general goal of any API design would be to treat the API as a first-class citizen,
and *not* the implementation. That is why I proposed org.apache.jspwiki as the one where the
API would live. 

It seems fairly clear that you and I are not going to agree. I confess I do not understand
who the API package is aimed at, why they need it, and how it makes things less confusing
for them rather than more. There has been no spontaneous developer uprising calling for a
separate API package, and the one developer (other than me) who has weighed in on it -- Murray
-- doesn't seem to like it.

Because we do not agree, it seems that the status quo should hold. In other words: continued
good class and interface design, appropriate refactorings for 3.0, and continued conversion
of concrete classes to interfaces + factories. (Example: what we've done with WikiContext).
 More of the same, but better.

That said, we *do* have to rename the package structure to org.apache.jspwiki.

Therefore, I recommend we simply make a straight 1:1 rename from com.ecyrd.jspqiki to org.apache.jspwiki,
and kill the API package. Let's vote on it.

> Rename packages to "org.apache.jspwiki"
> ---------------------------------------
>                 Key: JSPWIKI-38
>                 URL:
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>            Assignee: Janne Jalkanen
>             Fix For: 3.0

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message