incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Jaquith (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-38) Rename packages to "org.apache.jspwiki"
Date Tue, 30 Dec 2008 16:34:44 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-38?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12659843#action_12659843
] 

Andrew Jaquith commented on JSPWIKI-38:
---------------------------------------

Janne -- sorry, I did not mean to suggest you were somehow against interface extraction. We
do agree on this. Obviously, this particular discussion has raged for a while, and occasionally
precision eludes me.

You have recap'ped my counter-proposal accurately. I'd like to keep the interfaces in the
same packages (after we rename them to org.apache.jspwiki), and not put them in a separate
org.apache.jspwiki.api package, or in a separate package tree such as org.apache.jspwiki.api,
OR org.apache.jspwiki-api.

Not to put too fine a point on it, the burden on me is NOT to show that your idea is a bad
one. Because what you've suggested is a significant change, the burden is on you to show why
a separate .api package (or package tree) is warranted. I understand your reasoning but disagree
on the conclusion.

Consequently I will send out a message to the dev list requesting three votes:

* Immediate renaming of all packages from com.ecyrd.jspwiki to org.apache.jspwiki, so that
we can move to release an early alpha Apache build.
* Refactoring concrete classes (e.g., WikiEngine) into interfaces whenever possible, and supplementing
them with factory interfaces if warranted (e.g., interface WikiEngineFactory).
* Creation of the .api package/package tree, and creation of various types in this package
(e.g., WikiEngine, WikiPage)

I will vote +1 for the first two items, and -1 (veto) on the third with the recommendation
that we use existing (after-rename, org.apache.jspwiki) packages. The third vote is essentially
a retroactive vote.

Let's count 'em the votes. Smoke 'em if you got 'em.

> Rename packages to "org.apache.jspwiki"
> ---------------------------------------
>
>                 Key: JSPWIKI-38
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-38
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>            Assignee: Janne Jalkanen
>             Fix For: 3.0
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message