incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Jaquith (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-38) Rename packages to "org.apache.jspwiki"
Date Mon, 29 Dec 2008 22:49:44 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-38?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12659678#action_12659678
] 

Andrew Jaquith commented on JSPWIKI-38:
---------------------------------------

Murray -- my counter-proposal was that we eliminate the .api package and focus on refactoring
concrete classes into interfaces instead. I.e., WikiEngine becomes an interface in the top-level
package, and we provide a concrete class called DefaultWikiEngine (for example) that provides
the implementation. This could be combined with a factory class that produces WikiEngines.


This has already been done, partially, with WikiContext (even though the interface ended up
in the .api package, which I'd prefer us to avoid).

In other words: focus on refactoring by extracting interfaces, not shunting developers off
to another package. If we provide good interfaces, developers will use them in preference
to the concrete classes anyway.

> Rename packages to "org.apache.jspwiki"
> ---------------------------------------
>
>                 Key: JSPWIKI-38
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-38
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>            Assignee: Janne Jalkanen
>             Fix For: 3.0
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message