incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murray Altheim (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-38) Rename packages to "org.apache.jspwiki"
Date Tue, 30 Dec 2008 01:21:44 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-38?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12659716#action_12659716
] 

Murray Altheim commented on JSPWIKI-38:
---------------------------------------

Hi Andrew,

I do admit to some confusion in this discussion, with my apologies for any part I've played
in that confusion.

Yes, this was what I'd mentioned in my message of 28/Dec/08 01:52 AM. I have several instances
of an interface, a default implementation, and a factory all in the same package. I don't
have an aesthetic issue with that, and it does provide the advantage of being able to use
protected methods and member variables across the classes. It's also easy for the developer
to locate all of the components since they're in one place. 

I can likewise understand Janne's desire to have all of the APIs in one place too, as it's
a clear encapsulation of the set of guarantees being promised. If there's only to be *that*
set of APIs I think Janne's suggestion is a good one, but if there are other APIs littered
throughout the package hierarchy (and I suspect there are based on the current code) and those
APIs aren't guaranteed as stable as those in the api package, well, that's rather muddy. 

I do think that (based on my experience in the JDK, particularly with JAXP) that there are
advantages to both. But I wouldn't say I'm a fence-sitter on this, since the only way I think
a separate api package is a good idea is if *all* the APIs of the entire application live
there since that's what's suggested by its presence. If there are interfaces elsewhere I guess
a developer would assume those aren't guaranteed as stable, which is weird. Also, in the api
package we lose any sense of the API hierarchy and we end up mixing all sorts of things that
aren't really related except by being APIs. 

I do like the simplicity (for developers) for those classes we expect to have an interface,
a factory and a default implementation, that they live in one place. I'm trying to think how
this isn't simply a matter of taste or aesthetics.

After New Years as Janne suggested I'll download the JCR branch and take a look since I'm
only speculating. I'm kinda busy right now with a couple other things, playing catch-up. (What
are we doing not enjoying the holidays, anyway?)

> Rename packages to "org.apache.jspwiki"
> ---------------------------------------
>
>                 Key: JSPWIKI-38
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-38
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>            Assignee: Janne Jalkanen
>             Fix For: 3.0
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message