incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <>
Subject Re: interWikiRef links not working
Date Thu, 06 Nov 2008 21:41:36 GMT

My guess is that your you are editing file is not  
the same file as what JSPWiki is reading.  Happens to me all the  
time...  You could try removing that file (temporarily) and see if it  
affects JSPWiki operation at all.  If it doesn't, then find the right  
file.  If not... then there might be a bug, but frankly, I just can't  
figure out *how* it could possibly occur.


On 25 Oct 2008, at 18:00, Terry Steichen wrote:

> I've got this weird problem that cropped up.  I'm using 2.6.4.  In my
> I have a number of interWikiRef links defined,  
> one of
> which is:
>     jspwiki.interWikiRef.PSelect = Wiki.jsp?page=T.perspectives
> When I include that in a link, the substitution works just fine.
> However, I then copy and paste it as a new entry,
> changing the name slightly to this:
>     jspwiki.interWikiRef.PSelectx = Wiki.jsp?page=T.perspectives
> When I click on a link including the changed name, JSPWiki does not
> recognize the new link and assumes I want to create a new page.
> It appears to me that JSPWiki has - somehow - cached the previous  
> set of
> links and will not recognize any new ones.  I've restarted JSPWiki,  
> and
> deleted refmgr.ser, but to no effect.
> (I said that this just cropped up - I should say I just noticed it,
> because I haven't made many change to the collection of interWikiRef
> links for a while.)
> Any idea of what's likely going on here?

View raw message