incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Holeczek (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-333) language selection/detection doesn't always work
Date Wed, 20 Aug 2008 17:42:49 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-333?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12624064#action_12624064
] 

Florian Holeczek commented on JSPWIKI-333:
------------------------------------------

I gave an example: "Fehler: Not a valid login!" ... The first part is German, the second is
English.
Which locales are you using? In my case, Firefox 3 uses de-de, de, en, en-us in this order.
Have a look at http://wiki.bnv-gz.de:8080/ 
A Glassfish 2UR2 server is running there and it seems its language setting is English somehow
(don't know how and if this is configurable).

> language selection/detection doesn't always work
> ------------------------------------------------
>
>                 Key: JSPWIKI-333
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-333
>             Project: JSPWiki
>          Issue Type: Bug
>    Affects Versions: 2.7.x
>            Reporter: Florian Holeczek
>             Fix For: 2.8
>
>
> JSPWiki doesn't always detect the preferred language from the browser. The intended behaviour
is that if there is no user-pref cookie, the language setting *should* follow the language
of the browser.
> This is a collection of facts from several mails on the list.
> Florian reports:
> {quote}
> I've got a personal wiki installed on Tomcat 6, which runs without this problem. This
installation (v2.7.0-alpha-9) has been upgraded successively from 2.6.
> I've deployed the JSPWiki v2.7.0-alpha-9 on a Glassfish 2ur2 server and get English as
the default language for a not yet configured browser (without JSPWiki cookies), although
it is set to select de-de as primary language. It's the same with Firefox 3 and IE 7.
> However, switching to german language in the user preferences works.
> {quote}
> Janne reports:
> {quote}
> Yup, just checked.  It works on 2.6.3, but not on any 2.8 alpha releases.
> {quote}
> Harry reports:
> {quote}
> I tested against v2.7.0-svn-44   <http://zwiki.rabobank.nl/rss.rdf>, it doesn't
work there.
> I checked the source of the latest version, could not find anything reading the Language
header, just reading the cookie contents (mainly Preferences class).
> Some additional testing (all with FF3 on XP) confirm the same results as Janne :
> v2.7.0-svn-44 ==> doesn't work
> v2.7.0-alpha-9 ==> doesn't work
> 2.6.3-rc-2 ==> works
> {quote}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message