incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Haupt (JIRA)" <j...@apache.org>
Subject [jira] Created: (JSPWIKI-277) compatibility with java 1.6
Date Fri, 23 May 2008 08:37:55 GMT
compatibility with java 1.6
---------------------------

                 Key: JSPWIKI-277
                 URL: https://issues.apache.org/jira/browse/JSPWIKI-277
             Project: JSPWiki
          Issue Type: Improvement
    Affects Versions: 2.6.2
         Environment: java 1.6 sun jdk
            Reporter: Fabian Haupt
            Priority: Trivial


With the add of the two methods:
 public boolean isWrapperFor( Class<?> arg0 ) throws SQLException
    {  return false; }

    public <T> T unwrap( Class<T> arg0 ) throws SQLException
    {      return null;   }

(probably not a very usefull implementation, but it works anyways ;) )

in TestJDBCDataSource.java (com.ecyrd.jspwiki)

JSPWiki becomes runnable and compilable in java-1.6

This is just a _minor_ change, and so far I have encountered no problem running and building
jspwiki in java-1.6. As this wouldn't break anything with 1.5 maybe this could be added to
the svn?

greetings
Fabian Haupt

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message