incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <Janne.Jalka...@ecyrd.com>
Subject Re: NPE while creating user on the sandbox
Date Fri, 11 Jan 2008 21:11:57 GMT

Yup, my bad.  Config fault...

/Janne

On 11 Jan 2008, at 21:37, Florian Holeczek wrote:

> Hi folks,
>
> I just wanted to create a new user on sandbox.jspwiki.org and got a
> NullPointerException:
>
>> JSPWiki has detected an error
>>
>> Error Message
>>     An unknown exception java.lang.NullPointerException was caught  
>> by Error.jsp.
>> Exception
>>     java.lang.NullPointerException
>> Place where detected
>>     com.ecyrd.jspwiki.util.MailUtil.sendMessage(), line 266
>>
>> If you have changed the templates, please do check them. This  
>> error message may show up because of that. If you have not changed  
>> them, and you are either installing JSPWiki for the first time or  
>> have changed configuration, then you might want to check your  
>> configuration files. If you are absolutely sure that JSPWiki was  
>> running quite okay or you can't figure out what is going on, then  
>> by all means, come over to jspwiki.org and tell us. There is more  
>> information in the log file (like the full stack trace, which you  
>> should add to any error report).
>>
>> And don't worry - it's just a computer program. Nothing really  
>> serious is probably going on: at worst you can lose a few nights  
>> sleep. It's not like it's the end of the world.
>
> The data was:
> usera / usera / Jim Foo A / florian@holeczek.de
>
> My local Wiki (JSPWiki 2.6.1-cvs-6, too) doesn't have a problem with
> these data, but I haven't configured the mail function. So I guess the
> problem is located there.
>
> Regards,
>  Florian


Mime
View raw message