incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harry Metske (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-121) Drop support for JDK 1.4.
Date Sun, 06 Jan 2008 12:26:34 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-121?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12556368#action_12556368
] 

Harry Metske commented on JSPWIKI-121:
--------------------------------------

Well, I can live with that, I run my JSPWiki's everywhere with JDK 5 and up.
It looks like we've already started with this minimal requirement, my build just failed because
RenderingManager contains an annotation (    @SuppressWarnings("deprecation")) while the default
build.xml still has source=1.4 and target=1.4 for the compile targets.
Should that be changed ?

regards,
Harry

> Drop support for JDK 1.4.
> -------------------------
>
>                 Key: JSPWIKI-121
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-121
>             Project: JSPWiki
>          Issue Type: Task
>            Reporter: Janne Jalkanen
>             Fix For: 3.0
>
>
> Since Java 6 has been out for a long time, it's time to move to JDK 5.  We already require
JDK 5 to compile (due to some MBean classes we are using), but JSPWiki 2.6 should also work
on JDK 1.4.
> However, JDK 5 does give us quite a lot of advantages, programming-wise.  It makes loops
nicer, and generics and annotations make life so much easier.
> This shift is targeted to 3.0. In theory, we could start moving to JDK 5 even earlier
in 2.8, unless there's a large amount of opposition.  It's my understanding though that quite
a few companies are still running JDK 1.4.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message