incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Holeczek <flor...@holeczek.de>
Subject Re[2]: EmoticonsFilter in 2.6.0
Date Thu, 03 Jan 2008 15:34:26 GMT
I will take this opportunity to build JSPWiki on my own, because this
is something I'll have to do anyway sooner or later.

The other day I've read on the lists about migrating from jspwiki.org
CVS to Apache SVN. So where's the current code, I guess
http://www.jspwiki.org/wiki/AnonymousCVSAccess is outdated by now?

Regards,
 Florian

 
> 2.6 and 2.4 PageFilters are not API compatible.  You will need to
> recompile the Filter.  This is a pretty straightforward process,
> though, and it would be cool if someone could make it their job to
> update 2.4 filters to 2.6.

> (The reason for this is that the initialize() method didn't include a
> WikiEngine object, which made it essentially useless.  Also, a new
> destroy() method was added.  However, as Java does not have Java API
> versioning, there's really no way to know if the API works or not.  We
> might be able to resolve this with custom Annotations in the future
> (like @WorksWith2.6 or whatever).

> /Janne


Mime
View raw message