incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Holeczek <flor...@holeczek.de>
Subject Re[2]: add-on versioning rules, was: Re: EmoticonsFilter in 2.6.0
Date Fri, 04 Jan 2008 14:36:28 GMT
I didn't find any information about it. Where is it documented? Is it
a JSPWiki speciality or some common java stuff?

Regards,
 Florian
 
> BTW, you can already declare compatibility in your  
> jspwiki_module.xml.  It's a file which lists which versions your  
> module (plugin, etc) is compatible with.

> /Janne

> On 4 Jan 2008, at 15:08, Florian Holeczek wrote:

>> Hi everybody!
>>
>>> 2.6 and 2.4 PageFilters are not API compatible.  You will need to
>>> recompile the Filter.  This is a pretty straightforward process,
>>> though, and it would be cool if someone could make it their job to
>>> update 2.4 filters to 2.6.
>>
>> Thanks Janne, it was really easy. The EmoticonsFilter is working now,
>> just looking for contribution rules and after that I'll soon upload
>> it.
>>
>> The discussion on API changes a.s.o. let me think of the versioning
>> rules which were discussed on the lists a short time ago.
>>
>> I think it would be very useful to extend the versioning scheme by
>> rules for add-ons of any type (filters, plugins, providers,...) as a
>> recommendation to contributors.
>>
>> If I've understood the versioning proposal right, then for example
>> AddOnName-major.minor-AddOnVersion would already be sufficient for
>> stable versions, whilst for developer versions, the complete JSPWiki
>> version would have to be used.
>> Examples:
>> EmoticonsFilter-2.6-0.2.jar
>> EmoticonsFilter-2.7.2-svn-3-0.2.jar
>>
>> Regards,
>>  Florian


Mime
View raw message