incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dirk Frederickx" <dirk.frederi...@gmail.com>
Subject Re: JSPWiki styles not all working?
Date Thu, 03 Jan 2008 19:13:10 GMT
Janne,

Apparently tags such as <wiki:BaseURL /> or <wiki:Link format="url"
absolute="true" page="#$%"/> return url's based on
"http://www.jspwiki.org"
while the real url was "http://jspwiki.org".

How come ?

Another side effect of the new url is that cookies are lost and so are
you userpreferences

dirk

On Jan 3, 2008 10:22 AM, Dirk Frederickx <dirk.frederickx@gmail.com> wrote:
> Janne,
>
> Actually, some of the javascript needs to be able to compose the url
> based some prefix and a pagename. (eg. category style)
>
> I made some adjustment  to 'calculate' the url based on a dummy url
> (rendered according to the configured url scheme in the
> commonheader.jsp)  Apparently that dummy url seems not to match
> anymore. (this was ok previously)
>
>
>
>
> dirk
>
>
> On 1/3/08, Janne Jalkanen <Janne.Jalkanen@ecyrd.com> wrote:
> >
> > OK, *that's* interesting.  What do we have that relies on the baseurl
> > so much?
> >
> > /Janne
> >
> > On Jan 3, 2008, at 10:46 , Dirk Frederickx wrote:
> >
> > > Works perfect when using http://www.jspwiki.org;
> > > but not with http://jspwiki.org/
> > >
> > >
> > > dirk
> > >
> > > On 1/3/08, Dirk Frederickx <dirk.frederickx@gmail.com> wrote:
> > >> Indeed.
> > >> There seems to be a js error, when opening that page on IE6.
> > >> Need to investigate
> > >>
> > >> dirk
> > >>
> > >> On 1/3/08, Janne Jalkanen <Janne.Jalkanen@ecyrd.com> wrote:
> > >>> Hi guys!
> > >>>
> > >>> Before I report a bug, I just want to make sure I didn't screw up
> > >>> anything while upgrading the server... Are all the styles at
> > >>>
> > >>> http://jspwiki.org/wiki/JSPWikiStyles
> > >>>
> > >>> working for you all?  Dirk?
> > >>>
> > >>> /Janne
> > >>
> >
> >
>

Mime
View raw message