incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "maker su" <make...@gmail.com>
Subject Build failed on target "war-tomcat"
Date Thu, 20 Dec 2007 15:09:45 GMT
When compile JSPWiki-2.4.104-src on target "war-tomcat" with
apache-tomcat-5.5.25,there is an error.

compile-tomcat:
    [javac] Compiling 24 source files to
H:\localdev\workspace\JspWiki-src\JSPWiki\build\jsp-classes
    [javac]
H:\localdev\workspace\JspWiki-src\JSPWiki\build\jsp-java\org\apache\jsp\templates\default_\DisplayMessage_jsp.java:47:
replaceEntities(java.lang.String) in com.ecyrd.jspwiki.TextUtil cannot be
applied to (java.lang.Object)
    [javac]       out.print(TextUtil.replaceEntities(
pageContext.getAttribute("message",PageContext.REQUEST_SCOPE)));
    [javac]                         ^
    [javac] Note:
H:\localdev\workspace\JspWiki-src\JSPWiki\build\jsp-java\org\apache\jsp\templates\default_\FindContent_jsp.java
uses or overrides a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error

Please help.By the way,Is there any discussion forum for JSPWiki?

Thanks very much.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message