incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Jaquith (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JSPWIKI-33) Test webapps for web testing don't get undeployed
Date Fri, 21 Dec 2007 03:49:43 GMT

    [ https://issues.apache.org/jira/browse/JSPWIKI-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12553853
] 

Andrew Jaquith commented on JSPWIKI-33:
---------------------------------------

My theory here is that WIkiBackgroundThread is trying to access a Log4J class that, at shutdown
time, isn't guaranteed to be still loaded into memory. Thus, fixing this ought to be as simple
as removing references to classes (like Logger) that are neither part of JSPWiki.jar nor a
standard J2SE class.

> Test webapps for web testing don't get undeployed
> -------------------------------------------------
>
>                 Key: JSPWIKI-33
>                 URL: https://issues.apache.org/jira/browse/JSPWIKI-33
>             Project: JSPWiki
>          Issue Type: Bug
>          Components: Core & storage
>         Environment: windows xp, tomcat 5.5.25, JSPWiki 2.5.153cvs
>            Reporter: Juan Pablo Santos Rodríguez
>            Priority: Minor
>
> Test webapps used for web testing don't get totally or correctly undeployed. Almost all
of the webapp gets deleted except WEB-INF/lib/JSPWiki.jar, so after a few seconds it appears
as deployed in the tomcat manager. If I try to undeploy them again I get this Exception on
Tomcat (tried to undeploy them with Tomcat Manager and with build.xml script, same results
on both):
> java.lang.IllegalStateException
>         at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1248)
>         at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1208)
>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
>         at org.apache.log4j.spi.LoggingEvent.<init>(LoggingEvent.java:154)
>         at org.apache.log4j.Category.forcedLog(Category.java:388)
>         at org.apache.log4j.Category.error(Category.java:319)
>         at com.ecyrd.jspwiki.util.WikiBackgroundThread.run(WikiBackgroundThread.java:172)
> Exception in thread "JSPWiki Lucene Indexer" java.lang.NoClassDefFoundError: org/apache/log4j/spi/VectorWriter
>         at org.apache.log4j.spi.LoggingEvent.<init>(LoggingEvent.java:154)
>         at org.apache.log4j.Category.forcedLog(Category.java:388)
>         at org.apache.log4j.Category.error(Category.java:319)
>         at com.ecyrd.jspwiki.util.WikiBackgroundThread.run(WikiBackgroundThread.java:172)
> 10-nov-2007 17:07:11 org.apache.catalina.loader.WebappClassLoader loadClass
> So it seems that this WikiBackgroundThread is not properly closed.. hadn't many time
to look into it althought

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message