incubator-jspwiki-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <Janne.Jalka...@ecyrd.com>
Subject Re: Questions...
Date Thu, 15 Nov 2007 21:00:29 GMT

My guess is that

a) you're running a different tomcat or a different startup script  
than you think
b) this is some sort of a strange backslash vs forward slash issue (I  
don't use Windows, so can't help there)
c) Try using "==" instead of "="

I think the denial emails not being sent is a "missing feature" -  
it's really missing...

Andrew's really the workflow guru here.  Andrew?

/Janne

On Nov 13, 2007, at 02:28 , Dave Wolf wrote:

> ------=_Part_11810_17401928.1194913700586
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
>
> Hi,
>
> I've installed and configured JSPWiki and am running into a couple of
> problems that I've not been able to find a way around today. I  
> started at 7
> am this morning (its 4:30 pm now), so I feel like I'm just running  
> into
> brick walls, w/o much headway. Note: Tomcat v5.5.25 is installed as a
> service.
>
> The two problems are:
> Getting Tomcat (5.5.25) to see the policy and jaas files. I've  
> attempted
> several approaches:
>
>    1. Adding CATALINA_OPTS="-
>    Djava.security.auth.login.config=C:\WebContent\Wiki\jspwiki.jaas -
>    Djava.security.policy=C:\WebContent\Wiki\jspwiki.policy " to the
>    System Variables.
>    2. Adding -Djava.security.policy=C:\WebContent\Wiki 
> \jspwiki.policy & -
>    Djava.security.auth.login.config=C:\WebContent\Wiki\jspwiki.jaas to
>    the Java Options of the Tomcat Configuration tool.
>    3. Adding the content from the jspwiki.policy file to the end of  
> the
>    catalina.policy file.
>
> None of the above approaches have worked. The bottom line is that  
> the webapp
> fails unless there is a jspwiki.policy file in the <webapps>/ 
> jspwiki/WEB-INF
> directory.
>
> The other ?problem?, and this may be one of my expectations, is  
> that I've
> configured JSPWiki to require Admin approval for new registrations. No
> emails are being generated for denied registrations. Approval  
> registrations
> do result in sent emails, but none for those denied, bug or  
> feature?  Also,
> there doesn't seem to be a notification to the administrator group  
> or UI
> hint that one or more workflow items are pending.
>
> The Wiki is going to eventually become part of a grassroots partisan
> political site and so needs to be secure and provide notifications  
> to the
> members of the Admin group.
>
> Thanks In Advance!
> -- 
> Dave Wolf
>
> "Our lives begin to end the day we become silent about things that  
> matter."
> --Dr. Martin Luther King Jr.
>
> ------=_Part_11810_17401928.119491


Mime
View raw message