incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Vesse <>
Subject Re: IRI woes
Date Wed, 14 Mar 2012 16:09:58 GMT
Yeah I ran into the same thing the other week when the IRI package switched namespaces

A mvn clean package -U did the trick for me

(-U forces updates of dependencies)


On Mar 11, 2012, at 1:30 AM, Dave Reynolds wrote:

> On 10/03/12 21:57, Stephen Allen wrote:
>> I had the same issue with M2E.  I found the easy way to fix it was to
>> right click on the project, go to "Maven | Update Project
>> Configuration...", select the appropriate projects, click "Force
>> Update of Snapshots/Releases".  That seemed to fix things right up.
> Thanks.  I do routinely try Update Project Configuration but hadn't tried the "Force
update" option. I'll remember that for next time.
> I've an additional constraint that I'm working with OSGi so want the index to be up to
date as well and m2e doesn't seem to update .m2/repository/repository.xml reliably. So manual
reindexing is often needed anyway.
> Dave
>> -Stephen
>> On Sat, Mar 10, 2012 at 9:58 AM, Dave Reynolds
>> <>  wrote:
>>> On 10/03/12 15:18, Andy Seaborne wrote:
>>>> On 10/03/12 15:06, Dave Reynolds wrote:
>>>>> All of a sudden some jena-related projects are all failing to compile
>>>>> Maven, due to:
>>>>> java.lang.ClassNotFoundException: com.hp.hpl.jena.iri.IRIException
>>>>> They were working yesterday, indeed earlier this morning but m2e thought
>>>>> it would be a nice idea to update dependencies for me and everything
>>>>> broke.
>>>>> I can see IRI has shifted namespace but don't see why Maven is finding
>>>>> an inconsistent set of jars. I did have the dependency as
>>>>> jena-tdb:0.9.0-incubating-SNAPSHOT, changing that to
>>>>> jena-tdb:0.9.0-incubating didn't fix anything.
>>>>> No doubt some mess at my end and I'll have to nuke ~/.m2 yet again and
>>>>> start over.
>>>>> However, if anyone also experiences similar problems and finds the
>>>>> solution please let me know.
>>>>> Dave
>>>> Looks like you are picking up some post-release SNAPSHOT.
>>> Yes but not sure why.  A large scale nuke of ~/.m2 plus several cycles of
>>> reindex-local-maven/restart eclipse fixed it.
>>> Dave

View raw message