incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Castagna <>
Subject Re: [VOTE] Release jena-larq 1.0.0-incubating (RC-1)
Date Thu, 22 Mar 2012 18:28:13 GMT
Hi Andy, thanks.

Andy Seaborne wrote:
> the LICENSE file ends with:
> [[
> ==========================================================================
> The Apache License, Version 2.0 applies to the following libraries:
> Apache Lucene
> ]]
> but I don't see why. 


> * RAT:
> org.apache.jena.larq.TestLuceneNRT has no license
>   (I recently (13 March) fixed this in SVN)

My mistake, I missed that update.

> * Scripts
> The script bin/larq does not run
>    (classpath does not get set properly, no instructions on website)
> This works:
> mvn -q exec:java -Dexec.mainClass="larq.larq" \
> -Dexec.classpathScope=runtime  -Dexec.args="--help"
> except no log4j and it's clunky.

LARQ isn't distributed as a binary .zip distribution to be used by
non developers. I removed the shell scripts, now mvn package will
create a one jar which can be used to run commands easily.

Updated the README.txt file with instruction.
I'll update the website as well.

> Suggestion: Either hide in documentation or fix.
> * Website
> Make documentation quick link "LARQ - Free Text Search"

I did this, but I shouldn't have... now we have a serious problem
in staging... the navigation bar does not work because all "_"
became "-". I don't know why.

And, I do not know if I can revert that, because of the buildbot.

I tried to ask #asfinfra this morning, but I am not sure that is
the best channel (no reply). I'll try different channels.


View raw message