incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Seaborne <>
Subject Re: Getting TDB command line utilities running on a Mac OS X?
Date Wed, 25 Jan 2012 15:47:03 GMT
On 24/01/12 22:59, Damian Steer wrote:
> On 22 Jan 2012, at 23:45, Damian Steer wrote:
>> On 20 Jan 2012, at 17:39, Robert Vesse wrote:
>>> 1 - TDB won't build on my Mac unless I disable the tests because
>>> I get a whole bunch of Java heap memory errors, I tried using
>>> MAVEN_OPTS to set -Xmx8g but I still get 71 errors which cover
>>> three main errors - Java heap space, OutOfMemoryException and
>>> failed to initialize TestDynamicDataset
>> Confirmed on my mac. Boosting the heap won't help on 64 bit
>> systems, since the buffers are outside the java heap. (Looking at
>> it run the build barely breaks 25Mb). Mysterious.
> Tried this using the oracle preview of jdk 7 and it's fine. I find it
> hard to work out what's going on with the tests, but poking around I
> see nothing strange at all, and the process isn't using much memory
> at all.
> Damian

I don't immediately see why TestDynamicDataset is special in anyway. 
The failing to initialize is often a sign an earlier test messed up. 
What's the first failure you get (using the current SVN if poss because 
I fixed some test ordering some time recently ... but that only happened 
when running partial suites).

The only oddity I know of on OS/X is that large files with holes in get 
counted as having allocated all the bytes, unlike other unix'es where 
the "du -sh" size is only allocated space.


View raw message