incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Seaborne <>
Subject Versions: Xerces/XercesImpl and ICU4J
Date Fri, 09 Dec 2011 12:20:57 GMT
If we want to upgrade, now would be good time.


We currently use 2.7.1. (= 2005-07)

Proposal: version 2.10.0

   June 2010, which is the latest in Maven central.

There is a 2.11.0 (Nov 2010) but it's not in maven central (nor Apache).

So 2.11.0 is possibly bug fixes but the download of difficult available 
is IMHO not worth it if all our tests pass.  jena-core passes


We use 3.4.4 (March 2006); latest is (August 2011)

I tried the newest version and some test (punycode) in the IRI library 
failed, or rather failed to fail as they look like negative tests).

It would be good if some one tried out other versions to see where 
changes impact us come from and/or fix the tests.  (You probably want me 
to sort the rest of the release issues out!)

Default: leave as is


View raw message