incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Seaborne <>
Subject Re: issues building TxTDB
Date Tue, 15 Nov 2011 14:51:06 GMT
On 14/11/11 23:49, Simon Helsen wrote:
> Andy,
> somehow, I am not able to resolve this. Here are the steps I am following:
> 0) I made sure I am up-to-date with SVN
> 1) I removed any trace of the arq build in my .m2, just to make sure
> nothing old is used
> 2) I ran mvn install for iri, jena2, and arq (and I checked that the arq
> in my .m2 is new)

mvn clean install - avoid stuff in target/ (I've seen timestamp problems 

> 3) I then ran mvn clean test (and first cleaned tmp/testing) in TxTDB
> I keep seeing problems and it clearly uses the ARQ as built in step 2 (I
> don't see how it can use anything else).
> What am I missing?
> Simon

You're not missing anything.  The problem has now shown up in Apache's 
Jenkins  CI.  Changes were out of step.  When it originally worked, it 
was because of lack of sync, and now that has resolved itself into an 

Error fixed.

BTW Expect some shuffling of code from TDB to ARQ for a few days while 
interfaces get pushed up into ARQ for transactions and completing the 
API.  It isn't a one-shot reshuffle so there may be some turbulence and 
during that time, Jenkins has a habit of not quite being in sync.  It 
sorts itself out eventually.


View raw message