incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Seaborne (Commented) (JIRA)" <>
Subject [jira] [Commented] (JENA-36) can be a surprise
Date Fri, 04 Nov 2011 13:11:00 GMT


Andy Seaborne commented on JENA-36:

More style than necessity:

Would it be better to call the properties file "" -- it's being
explicitly set by the code and so we can use a name that is not the default (the original
issue with JIRA)

Turning on /off around the test or the suite is, to me, the best way.  (I do this a lot in
ARQ testing for changes to internal global switches).

There is code (in Atlas) to turn logging on and off programmatically for specific classes,
but you have to call the log4j / JUL levels directly.

org.openjena.atlas.logging.Log#enable #disable.
> can be a surprise
> ----------------------------------
>                 Key: JENA-36
>                 URL:
>             Project: Jena
>          Issue Type: Bug
>            Reporter: Benson Margulies
>            Assignee: Paolo Castagna
>            Priority: Minor
> The jena jar, and perhaps others, has a on behalf of the commands. A
little classpath confusion can end up with this at the head of the line of an app that is
incorporating the jar.
> It would be more better, if you ask me, for the commands to use the -D for log4j to ask
for a different file name, and leave *that* in the jar.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message