incubator-jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Castagna <>
Subject ARQ does not compile with Eclipse using JDK 1.6.x
Date Mon, 13 Dec 2010 15:58:26 GMT

I have a machine with JDK 1.6.0_16 installed and when I checkout ARQ I see
compile errors in Eclipse.

   "Access restriction: The field END_DOCUMENT from the type XMLStreamConstants
    is not accessible due to restriction on required library
    /ARQ/src/com/hp/hpl/jena/sparql/resultset	line 306"


.classpath says:

<classpathentry kind="con" 

But, I don't have JDK 1.5.x installed, so Eclipse is using JDK 1.6.0_16
and I see the errors.

Easy/quick to fix, is it just my problem or others have seen this?

Also, this reminded me... Jena, ARQ, TDB, etc. do they require/assume
JDK 1.5.x or 1.6.x?


View raw message