incubator-ivy-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akash Jain (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVYDE-61) Eclipse hangs on startup
Date Mon, 03 Sep 2007 22:16:57 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-61?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12524585
] 

Akash Jain commented on IVYDE-61:
---------------------------------

Just a note, a number of our developers are seeing this on both Linux and Windows.  Creating
a new workspace fixed the issue for us, we will try doing the ivy file swap-out as well.

> Eclipse hangs on startup
> ------------------------
>
>                 Key: IVYDE-61
>                 URL: https://issues.apache.org/jira/browse/IVYDE-61
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 1.2.0
>         Environment: Sun Java  1.6.0-b105, Eclipse 3.3, Ubuntu 7.04 32 bit, AMD Sempron
2800+
>            Reporter: Nigel Charman
>         Attachments: .options, build.out, debug.sh
>
>
> I've been using IvyDE on my project for around a month, and have had no problems with
it up till now.
> Eclipse hangs at startup on the splash screen with the progress bar about 2/3 full. This
only occurs with one of my workspaces; Eclipse starts OK with the other workspaces. 
> After removing the IvyDE plugin and features folder Eclipse starts OK.  Reinstate the
IvyDE plugin and features folders and Eclipse hangs.  
> The following actions had no effect and Eclipse still hung on startup:
> - rebooting 
> - leaving Eclipse for an hour to start up
> - invoking Ivy retrieve from the ant script of the affected project
> - deleting the Ivy cache
> The eventual workaround was to delete the ivy.xml.  After this Eclipse started OK.  I
then reinstated the ivy.xml file and everything now works OK, including restarting Eclipse.
> At the time of error the Eclipse .log file contains:
>  !SESSION 2007-08-01 22:54:12.565
>  -----------------------------------------------
>  eclipse.buildId=I20070625-1500
>  java.version=1.6.0
>  java.vendor=Sun Microsystems Inc.
>  BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_NZ
>  Command-line arguments:  -os linux -ws gtk -arch x86
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-08-01 22:54:25.592
>  !MESSAGE starting IvyDE plugin
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-08-01 22:54:25.626
>  !MESSAGE IvyDE plugin started
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-08-01 22:54:26.471
>  !MESSAGE resolved dependencies of /home/nigel/jibx/jibxws/build/ivy.xml
> =============================================================================================================
> On successful startup the Eclipse .log file shows:
>  -----------------------------------------------
>  eclipse.buildId=I20070625-1500
>  java.version=1.6.0
>  java.vendor=Sun Microsystems Inc.
>  BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_NZ
>  Command-line arguments:  -os linux -ws gtk -arch x86
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-07-29 20:19:47.736
>  !MESSAGE starting IvyDE plugin
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-07-29 20:19:47.887
>  !MESSAGE IvyDE plugin started
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-07-29 20:19:59.523
>  !MESSAGE resolved dependencies of /home/nigel/jibx/jibxws/build/ivy.xml
>  !ENTRY org.jayasoft.ivyde.eclipse 1 0 2007-07-29 20:20:01.112
>  !MESSAGE resolved dependencies of /home/nigel/jibx/jibxws/build/ivy.xml
> =============================================================================================================
>  Note the "resolved dependencies" message is duplicated here on successful startup. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message