incubator-isis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Moores <>
Subject Re: Smoke Test
Date Sat, 09 Apr 2011 11:06:54 GMT
Hi Dan

I dropped the archetypeCatalog property from my maven build and when I run:

    mvn archetype:generate \

I end up with a standard empty Maven project because Maven doesn't resolve the archetype from
my local repo.

After a couple of attempts I found the following worked:

    mvn -o archetype:generate \
            -DarchetypeArtifactId=quickstart-archetype \
            -DarchetypeVersion=0.1.2-incubating-SNAPSHOT \

The archetypeVersion is required.  It could be that I need to specify the archetypeRepository
because I'm using a non-standard location for my local repo.

So, happy days. I've built locally, created the archetype and then created an example project
from my local build of the archetype.  The following modules were created:


I did note that if you run this without the -o option you get the following info messages:

[INFO] Unable to find resource ''
in repository quickstart-archetype-repo (/Users/andrewmoores/development/applications/maven/repository)

[INFO] Unable to find resource ''
in repository quickstart-archetype-repo (/Users/andrewmoores/development/applications/maven/repository)

But it still creates a new Isis project.


On 9 Apr 2011, at 09:59, Dan Haywood wrote:

> Hi Andrew,
> You're right, those instructions on the wiki "smoke test" page need updating. 
> Here's the scoop: when we first entered the incubator I wanted to document how to build
the source and try out an example app, mostly for the benefit of the other contributors but
also for anyone else (early adopter "users") who might be interested in exploring/trying out
Isis prior to us having pushed out our first formal release. 
> Since then I've got our archetype working and published to the apache snapshot repo,
which means that early adopters don't need to go to all the hassle of building source etc.
But, as you've pointed out, that page on the wiki doesn't quite say that. 
> That said, the version of the archetype on the snapshot repo is a little out-of-date;
I've updated it recently to also build/package a self-contained jar in the quickrun module.
  So if you do build from source then you can try out this updated version (just miss out
the 'archetypeCatalog' parameter so that mvn picks up from your local repo on ~/.m2
> Cheers,
> Dan
> Sent from my iPhone
> On 8 Apr 2011, at 18:12, Andrew Moores <> wrote:
>> Hi
>> I've just built from source and created a new app following the instructions on the
quick start page (  I don't see how
this is testing what I've just built?  Did it create the new app using the artifacts installed
into my local repos when I built from source? (Maybe, this more of a Maven question).
>> Thanks
>> Andrew

View raw message