incubator-isis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Haywood <dkhayw...@gmail.com>
Subject Re: Something's wrong with the "shaded" jar
Date Sat, 16 Apr 2011 17:01:27 GMT
I'm presuming this was inspired by my adding the shade plugin to create 
an uber-jar for the Maven archetype?

One of the things this approach requires is that isis.properties can be 
found on the classpath.  You might remember I raised this on the mailing 
list [1], moving isis.properties from config to src/main/resource.

So, you'll need to do the same for the claims example also.  (See the 
support/quickstart/quickrun module by way of comparison).

Are you happy to make this change?

Cheers
Dan

[1] 
http://mail-archives.apache.org/mod_mbox/incubator-isis-dev/201103.mbox/%3Caf25e170cd7c4fe7b197c60dcd3bc40a.squirrel@webmail.kmz.co.za%3E

~~~~~~~~

On 14/04/2011 19:35, Kevin Meyer - KMZ wrote:
> When I try and run an uber-jar made from the claims example, (or
> support/quickstart), the "java -jar *.jar" command on the resulting jar
> fails with:
>
> Exception in thread "main"
> org.apache.isis.core.commons.exceptions.IsisException: failed to load
> 'isis.properties'; tried using: [file system (directory 'config'), file system
> (directory 'src/main/webapp/WEB-INF'), context loader classpath]
>
>
> I tried copying the /WEB-INF directory to /config in the archive, and it
> picked up the isis.properties once, but failed with the same error again
> later. Now I can't even get this far...
>
>
>
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message