incubator-isis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Burton <mi...@mycosystems.co.uk>
Subject Re: Build
Date Thu, 02 Dec 2010 20:08:57 GMT
Now I'm trying to run the webapp-based Scimpi viewer...

mvn jetty:run  gives error:
The plugin 'org.apache.maven.plugins:maven-jetty-plugin' does not exist...

I tried deploying Scimpi.war into my existing Tomcat6 but it clashes with commons-logging.jar,
then servlet-api (the app has its own copy in its lib/), then I get a StartupServletContextListener
NoClassDef (MyFaces clash??)

I also tried running the .launch and got: 
  Launch configuration prototype-viewer-bdd references non-existing project org.apache.isis.support.prototype-viewer-bdd
but this project does seem to exist.

Tried a build/ clean in Eclipse and got several errors like:
org.eclipse.debug.core.DebugException: org.xml.sax.SAXParseException: Content is not allowed
in prolog. occurred while reading launch configuration file: /Users/mikeburton/DEV/ISIS/projs/isis01/support/archetypes/exploration/target/classes/archetype-resources/ide/eclipse/launch/Isis
(DnD).launch.
	at org.eclipse.debug.internal.core.LaunchManager.createDebugException
I guess I need to process the 3    #set(    lines at the top of the .launch file somehow?

My preference would be to get  mvn jetty:run  to work but the Eclipse stuff would be "nice
to have"

Any ideas please?


Best Regards

Mike Burton

On 2 Dec 2010, at 18:15, Mike Burton wrote:

> Hi Dan,
> 
> Re my earlier error with servlet-api-2.5.jar I tried your suggestion,
> I deleted the ~/.m2/.../2.5 folder so that Maven would re-fetch it, but got the same
error.
> Looking back through the build output for when it downloaded servlet-api-2.5.jar (from
https://maven-repository.dev.java.net/nonav/repository/javax.servlet/jars/ ) it got a "checksum
failed" error.
> 
> So I downloaded servlet-api-2.5.jar also .pom and also the .sha1 files for them both,
from http://repository.jboss.org/maven2/javax/servlet/servlet-api/2.5/ instead, into my Maven
repository.
> 
> Now  mvn clean install -D modules=all -o  works. I just get one test failure:
> /tmp/concordion/org/apache/isis/support/prototype/stories/NewClaimDefaultsOkStory.html
> Successes: 17, Failures: 1
> 
> 
> Best Regards
> 
> Mike Burton
> 
> 
> 
> 
> On 19 Nov 2010, at 11:07, Dan Haywood wrote:
> 
>> Hi Mike,
>> thx for taking the time... within
>> 
>> On 19/11/2010 10:28, Mike Burton wrote:
>>> Hi Folks,
>>> 
>>> Just built on my Mac, using Maven 2.2.1 and JDK 1.6.0_22
>> +1.
>> 
>> BTW, I think the standard build ("clean install") should work on Maven 3.0 (Vango
reported as such), but my understanding is that mvn 3.0 has rejigged the way that the site
plugin works, so "site-deploy" won't.  There's a JIRA ticket for this [3] ... until we tackle
it, I think we should say that Maven 2.2.1 is the only version of Maven we're supporting.
>> 
>>> Apologies if some of these have already been reported...
>>> 
>>> 1. mvn clean install  succeeds, but some test failures in alternatives/objectstore/nosql/target/surefire-reports:
>>> org.apache.isis.alternatives.objectstore.nosql.DestroyObjectCommandImplementationTest.txt
>>> org.apache.isis.alternatives.objectstore.nosql.NoSqlObjectStoreTest.txt
>>> org.apache.isis.alternatives.objectstore.nosql.ObjectReaderTest.txt
>>> org.apache.isis.alternatives.objectstore.nosql.SerialKeyCreatorTest.txt
>>> org.apache.isis.alternatives.objectstore.nosql.SystemTest.txt
>>> org.apache.isis.alternatives.objectstore.nosql.WriteObjectCommandTest.txt
>> Not sure, "works for me".
>> 
>> Rob, any clues?
>> 
>> 
>>> 
>>> 2.  mvn clean install -D modules=all
>>> [ERROR] error: error reading /Users/mikeburton/.m2/repository/javax/servlet/servlet-api/2.5/servlet-api-2.5.jar;
cannot read zip file
>> This looks like a corruption in your local Maven repo.  Just delete that JAR (or
even the "2.5" directory) to force Maven to download again.
>> 
>> Once you do get a clean build, I recommend "-o" to speed up subsequent builds.
>> 
>> 
>>> 
>>> 3. mvn site-deploy -D modules=standard -D site=full -D deploy=local
>>> [INFO] Velocimacro : adding VMs from VM library template : VM_global_library.vm
>>> [ERROR] ResourceManager : unable to find resource 'VM_global_library.vm' in any
resource loader.
>>> ...
>>> .. Cobertura... [INFO] There are 3 checkstyle errors.
>>> ...
>> Don't worry about checkstyle stuff just yet... we'll tackle that later on.
>> 
>> 
>> 
>>> Missing: com.java:jimi:jar:1.0
>>> for artifact:   com.agilejava.docbkx:docbkx-maven-plugin:maven-plugin:2.0.8
>>> 
>> It's necessary to install the JIMI jar first.  There is a note in the trunk/pom.xml,
but I've also just updated the BuildProcess page on the wiki [1] to document this as a prereq
>> 
>> 
>> 
>> 
>>> 4. For completeness we need to add this to beginning of build instructions:
>>> 
>>> Make a directory and download the software into it:
>>>   svn co http://svn.apache.org/repos/asf/incubator/isis/trunk .
>>> 
>> Done, in [2]
>> 
>>> Allocate sufficient memory for the JVM, to avoid heap space error in Maven:
>>>  export MAVEN_OPTS=-Xmx512m
>>>  //TODO  or the Windows equivalent
>>> 
>> This is documented already, in [2]
>> 
>>> Maybe add   svn  to list of prerequisites? or is that too obvious?
>> Done, in [2]
>> 
>> 
>>> Mike
>> Mike ... if you haven't already, register on the wiki and send a mail here to isis-dev
to get write permissions.  Mark is the man with the karma to hand out the karma.  Then you
can make any updates directly yourself ;-)
>> 
>> 
>> [1] https://cwiki.apache.org/confluence/display/ISIS/BuildProcess
>> [2] https://cwiki.apache.org/confluence/display/ISIS/SettingUpDevelopmentEnvironment
>> [3] https://issues.apache.org/jira/browse/ISIS-11
>> 
> 


Mime
View raw message